Can not connect thru python

Hello there,

i’m trying to connect an RPI 0W, equiped with the gate container (updated to firmware 3.2) and all i can get is “ConnectionRefusedError: [Errno 111] Connection refused”

The same RPI 0W and the corresponding sd card worked well few times ago, but now i can not reach to connect using Robot(“”) nor Robot("/dev/ttyS4").
What am i supposed to do ? i do not understand. I upgraded pyluos on my computer, i upgraded gate container firmware, i even tried to change the router. I am now desperate : any idea ?

Thank you !

Okay, after many tries, my guess is that i’ve upgraded pyluos on my ubuntu18, i have upgraded firmware on gate container, so should i upgrade something on RPI0W ? is there any firmware to upgrade on the raspberry pi itself ? anyway to do it ?

@Nico is the expert for that, he will be back in a week and half, but I’m almost positive that nothing has to be updated on the Raspberry Pi side.

What you can try is to delete the file /Volumes/boot/wpa_supplicant.conf, restart the Rspberry Pi and configure again the Wifi.

I changed my config on this specific project, using a Low-power BLE/wifi Container does work in my case.

Is it for me? 🤔