Dynamixel container Command

I’ve tried the command for dynamixel motors

Good news are OK :


-> no change of velocity

Result is strange …at first type my robot was compliant on 6 motors …whith false command on the 6 motors, only the motor 1 seems to be stiff.

Then after use of give position on the 6 motors its impossible now to make them compliant again.

and the worst

How to solve these problems ?

Here is a lot of bugs!

I have to look at it for this one.

We already see similar bug on other containers, for now we think this is due to the quantity of messages send at the same time. @Simon patch this one by adding small time.sleep(0.1) between each commands. We have to look at this one too.

This one is really weird, I add it to my bug list…

The last one is on me, Wheel mode is not really managed for now I forgot to remove it on Pyluos. It’s already on my bug list, I will make it work as soon as possible.

first, the compliant bug. I found a big bug but I am not really sure the bug I fix is the one you describe. After fixing this big bug I try to reproduce your situation. I don’t have XL320 anymore so I use V1 motors instead and I don’t see any problem with compliance and position read.
either this new revision fix your issue or this problem only appear with XL320.
Can you update your Usb container to firmware revision 0.1.1 and try again please?

About the speed bug, I found a mistake in the speed computation, so I fix it. (For your information motor speed unit is RPM). I took advantage to manage wheel mode too :wink: .
For wheel mode you have to update pyluos to revision 1.0.6.

Please let me know if you experiment any trouble with all of this.

Thank’s a lot for your patience and your huge contributions.

good job it’s better & better
I’ve updated my usb container with Usb_0.1.1.bin.zip
and dynamixel with
i’ve also updated pyluos with the command
pip install --user --upgrade pyluos

Now let see the test :

:grinning:bingo all my motor are here !

I alternate the cells
:grinning: Great all my 6 motors alternate stiff or compliant

The command
the motor move even if it is in compliant mode …:thinking: why not …

but more strange …
After the command “give position” make motor compliant doesn’t work properly
compliant = TRUE …the motor is always stiff
and now if you test command
compliant = false and after compliant = True now the motor is really complaint.

The command
seems having no effect
the motor move always with the same velocity with the command

That’s all folk today :sleeping:

Good new !

I don’t have this one with my MX-64 :fearful: I can’t find any mention of this behavior in the XL320 documentation! I will have to try it with XL320, we order some of them to be able to do tests…

Indeed, the problem was in target position, I fixed it in the new pyluos revision 1.0.7. Sorry but you will need to update pyluos again.

Again, velocity is working fine on my MX-64, I will have to test it with XL320, you will have to wait next week…

Did you try the wheel mode?


It was late yesterday, but if you ask about

It was always something like that …perhaps because of DXL ?

I hope there is no limit on number of update :grinning:

I remove this line on the new revision of pyluos, update it and check if your revision is 1.0.7. That should fix this one.

Don’t worry there is not :wink:

@Luc, I received my XL320 so I can run some test to reproduce your bugs.

With the last revision Speed seems to do something on motors movement when we change target position, but wheel mode doesn’t do anything.

I get it, this is because to set XL320 in wheel mode we have to disable torque… So I disable the torque and re-enable it after setting wheel mode and now it’s working!

I push a new release for your container Dynamixel_V2_0.1.2.bin

Let me know if everything is working now.

Great ! Everything is solved now for the problems evoked on dynamixel containers.

One question remains on “firmware_revision” this methods always answer “Unknown”


oops, I forgot this one !

Have you tried to execute it multiple time?
This command is special because python send a request and just wait a bit to print the value that should be received back. I noticed that serial driver depending on the OS can introduce a little more delay to output the python command.

So if you execute it multiple time do you have a result?

For the DXL
Same result after multiple time …

For the GPIO after the second time :

Strange …Normally GPIO has been updated with Gpio_0.1.0.bin

Ok, I add it to my bug list. Thank you to highlight it.

Is it for me? 🤔